[cloud 2] [us-central-1] Incorta services performance degradation

Incident Report for Incorta Cloud

Resolved

The Issue has been resolved. We will update the status page with the RCA
Posted Nov 23, 2025 - 14:38 UTC

Investigating

Investigating - We are facing some performance issues impacting Incorta services on Cloud 2 [us-central-1],
This may impact the load plans during this time we are currently working to get it fixed ASAP.
Posted Nov 23, 2025 - 13:41 UTC
This incident affected: Google Cloud Platform Regions (GCP - US Central 1 (Iowa)).