GCP Major outage

Incident Report for Incorta Cloud

Resolved

We wanted to let you know that the Google Cloud Platform (GCP) issue has been resolved, and all of our services are now back to normal.

We apologize for any disruption or inconvenience this may have caused. We appreciate your patience as we worked to restore full functionality.

If you experience any lingering issues, please don't hesitate to contact our support team.
Posted Jun 12, 2025 - 23:07 UTC

Identified

Multiple GCP products are experiencing outage impacting incorta cloud workloads
Posted Jun 12, 2025 - 18:45 UTC
This incident affected: Google Cloud Platform Regions (GCP - US Central 1 (Iowa), GCP - US West 1 (Oregon), GCP - Europe West 2 (London), GCP - Middle East Central 1 (Doha), GCP - Middle East Central 2 (Dammam), GCP - Asia South East 1 (Singapore), GCP - Asia North East 1 (Tokyo)).